SAP Jobsuche bei DV-Treff


Suchen
Consultant81
vor 29 Tage
Hallo zusammen,

wir haben bei einem Kunden das ECC von Oracle auf HANA DB umgestellt.

Das ERP ist nicht S/4 HANA, sondern noch ECC 6.0.

Kurz nach der Umstellung haben wir eine Meldung von einem Key User erhalten, dass bei der Anlage von Nacharbeitsaufträgen (mit Material) die Fertigungsversion nicht gelesen werden kann.

Die Auftragsart ist in den auftragsartabhängigen Einstellungen so eingestellt dass zwar ein Arbeitsplan aber keine Stückliste gezogen werden kann.

Die BOM Application hat hierbei eine Selection ID hinterlegt die immer ins "Leere" läuft.

Prinzipiell ist dies gewollt und führt bei Auftragsanlage i.d.R. dazu, dass ein Arbeitsplan aber keine gültige Stückliste gefunden wird.

In manchen Fällen sollen dennoch Arbeitsplan und Stückliste aus der Fertigungsversion mit der Funktion "Stammdaten nachlesen" gelesen werden.

Im Pop-up gibt es ein Feld Fertigungsversion, wenn dieses angeklickt wird, erscheint kein weiteres Pop-up , in dem die Fertigungsversion ausgewählt werden kann.

Es existiert immer eine gültige Version, diese wird jedoch nicht gefunden.

Gemäss aktuellem workaround muss die Fertigungsversion manuell eingetragen werden, damit diese gefunden und die Stammdaten nachgelesen werden können.

Man könnte an dieser Stelle sagen, dass das System arbeitet wie es eingestellt ist.

Dummerweise verhält sich das alte System mit der alten Datenbank (Oracle) anders, hier kann die Fertigungsversion ausgewählt werden.

Jetzt stellt sich die Frage, wo der Fehler liegt im "alten" oder neuen System.

Zur Klärung dieser Frage wurde ebenfalls eine OSS Meldung an die SAP eröffnet.

Auf diese haben wir bisher noch keine Antwort.

Würde mich freuen, wenn einer von euch ähnliche Erfahrungen gemacht hat bzw. das Thema bekannt ist.

Danke und Gruss,

C81

daytona80
vor 25 Tage
Hallo,

äußerst spannend aber an sich sollte sich die Prozesslogik im SAP durch einen DB Wechsel nicht ändern, es sein denn ihr nutzt Z Logik und fangt bspw. Select Schleifen im HANA nicht wie vorgeschrieben mit eindeutigen "Order by..." ab. Habt ihr vorher ein CodeCheck durchgeführt?


Vielen Dank und viele Grüße
Consultant81
vor 10 Tage
Hallo,

das haben wir uns ebenfalls gedacht. Tatsächlich ist uns aufgefallen, dass einige Programme, die nicht gründlich genug getestet wurden, nicht sauber liefern wenn in Select-Schleifen die "Order by..." - Anweisung falsch verwendet wurde. Fehler dieser Art wurden jedoch schnell gefunden und korrigiert.

In diesem Fall ist jedoch keinerlei Z-Logik aktiv, es handelt sich im Prinzip um die F4-Suchhilfe.

Wir haben schließlich versucht den Quellcode an der Stelle zu debuggen, haben jedoch irgendwann abgebrochen.

Anschliesend wurde eine OSS Meldung eröffnet. Auf diese haben wir nach 5 Wochen keine Lösung aber erstmals eine Reaktion erhalten.

Ich werde das Gefühl nicht los, dass der SAP Support schlechter wird oder war das schon immer so?

In den letzten Jahren waren die Reaktionszeiten (PP, SAP ME - Umfeld) eher schlecht.

Selbst bei Meldungen mit hoher Prio hat es einmal 4 Wochen gedauert bis diese einem Bearbeiter zugeordnet wurde...

Ein anderes Mal hieß es nach 6 Monaten und unzähligen Eskalationen das "sei so nicht im Design vorgesehen". Danke für Nichts.

Mal sehen was bei dieser Meldung herauskommt.